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MOZILLA FIREFOX 
FIREFOX IS THE PREFERED POWERSCHOOL BROSWER. ALL 

POWERSCHOOL APPLICATIONS ARE CREATED TO WORK 

BEST USING FIREFOX. 

IMPORTANT LOGIN INFORMATION 
 All CMS Teachers & Staff will login to their RadpidIdentity/NCEdCloud accounts to access all PowerSchool and Homebase Applications using FireFox 

 Users should CLEAR HISTORY & COOKIES each day from FireFox and Chrome + Logout of their NCEdCloud and PowerSchool Accounts 

 Passwords are created by the user 

 Users who forget their NCEdCloud Account Password will Click the Need Help Link on the RapidIdentity login screen and Select Forgot Password to reset 

their NCEdCloud password 

 DO NOT BOOKMARK or CREATE A DESKTOP ICON to access PowerSchool, PowerTeacher, PowerTeacher Pro Gradebooks, or Homebase Applications as 

the programs will not function or operate from bookmarks or desktop icons 

1. RapidIdentity/NCEdCloud URL: my.ncedcloud.org 

NEW CMS TEACHERS/STAFF 

 New CMS Teachers/Staff Members are required to “Claim My Account” before accessing PowerSchool/PowerTeacher accounts. It 

is highly encouraged that new CMS teachers/staff utilize the CMS Claiming Your NCEdCloud Account QRC found on the CMS 

Intranet/PowerSchool Updates & Information Site (Navigation: my.cms.k12.nc.us > PowerSchool Updates & Information > Training 

Documents and Videos > NCEdCloud Related). 

 New CMS Teachers/Staff will use FireFox and URL: my.ncedcloud.org to complete the Claim My Account process. 

 From the RapidIdentity Login Screen NEW teachers/staff will Click Claim My Account > New Users will be directed through the 

process 

 New users will create a RapidIdentity/NCEdCloud Password during the Claim My Account Process. 

 Upon completion new users will be directed back to the RapidIdentity/NCEdCloud Login Screen where they will enter their 

Username: 10 digit NC Employee ID Number & Password: Created during the Claim My Account Process. 

 From the NCEdCloud Application Page Teachers will Click the PowerTeacher Account Icon to Access their PowerTeacher Account, 

all teachers will verify their school is correct/accurate. 

 Any teacher who is unable to access their PowerTeacher account OR if the school of assignment is not correct he/she will verify with 

the school Sr. Administrative Secretary that they are entered in Staff Maintenance and/or Data Manager that he/she has submitted 

a PowerSchool Security (Technology) Cherwell Ticket to create or update their PowerTeacher account. Once these steps have 

been completed, teachers will be able to access their PowerTeacher Account and the school of assignment will be updated. 

2. Enter Username > Click Go 
NOTE: 

Username= 1- Digit NC Employee ID Number 

3. Enter Password > Click Go 
FORGOT PASSWORD? 

Click Need Help > Forgot Password to Reset 

4. Open PowerTeacher > Click the PowerTeacher Icon 
NCEdCloud Account Passwords/Updates: 

Click Profiles > Change Password or Update Account as necessary 

         

PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Accessing the PowerTeacher Account  

All Charlotte-Mecklenburg School teachers and staff members are required to have an active CMS Email Account and be 

entered ito PowerSchool Staff Maintenance at their currently assigned school before PowerSchool Security can create or 

update their PowerSchool/PowerTeacher account. All new PowerSchool/PowerTeacher and/or exsisting 

PowerSchool/PowerTeacher account updates require a PowerSchool Secuity (Technology) Cherwell Ticket, submitted by 

the school Principal or Data Manager. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

GOOGLE CHROME 
POWERSCHOOL APPLICATIONS ARE OPERATIONAL USING 

THE GOOGLE CHROME BROWSER. WHEN FIREFOX IS 

UNAVAILABLE CHROME MAY BE UTILIZED. 
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Verify School 

Assignment Select School Dropdown 

Box 

PowerTeacher Pro Gradebook  
Link/Access  
Teachers will access the 
PowerTeacher Pro Gradebook using  
the PowerTeacher Pro link in the  
Navigation Menu or in the Current  
Class list. 

Print Class Reports 

Seating Chart 
& 

Seating Chart Attendance 
Entry & Submission 

Student Data/Information 
&  

Individual Student 

Reports 

Meeting/Period 
Attendance 

Entry & Submission 

Daily Attendance 
Entry & Submission 

Current Classes/Schedule 

Courses/Sections 

 

PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Navigating the PowerTeacher Account  

Charlotte-Mecklenburg School teachers will use their PowerTeacher account to take student attendance and access the 

new web based HTML gradebook, PowerTeacher Pro. Teachers have access to a variety of student information screens, 

student data, reports, the school’s staff directory, Schoolnet, and more. Knowing how to navigate the PowerTeacher 

account, specifically the Start Page will be essential in accessing teacher functions, submitting attendance, and accessing 

PowerTeacher Pro.    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NAVIGATION MENU LINK       AVAILABLE FEATURE/FUNCTION          

Start Page/PowerSchool Logo    Clicking on the Start Page link or on the PowerSchool Logo to return to the 

        PowerTeacher Start Page   

Daily Bulletin        View/Review the current or a historical school bulletin entered by school    

       administration   

Schedule        Provides the teacher schedule matrix with the option to show Co-Teacher    

        Sections, current sections, or all sections   

Staff Directory        Provides the teacher with a list of all school staff and their contact 

      information   

Personalize        Teachers may select their Default Student Screen and choose to show or    

       hide the section numbers on their Start Page.    

         NOTE:  Teachers will not change/modify their PowerTeacher account 

       Passwords using the Personalize > Change Password function.     

         PowerTeacher should only be accessed using the NCEdCloud.     

          Changes to the PowerTeacher password will not be saved.   

Reports         Used to run available student/class reports for all classes   

Schoolnet        Opens the teacher’s Schoolnet account   

Meals & Recommendations      CMS does not utilize the Meal or Recommendations functions/features   
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PowerTeacher for HIGH SCHOOL YEARLONG Courses: Entering & Submitting Attendance 

Charlotte-Mecklenburg School teachers are required to enter and submit attendance for each day that school is in session 

as required by the North Carolina Department of Instruction and Charlotte-Mecklenburg Schools Board of Education. All 

Elementary and Middle School teachers will enter Daily Attendance in their scheduled Homeroom class section within the 

first 45 minutes of the academic day. All High School teachers are required to enter meeting/period attendance within the 

first 15 minutes of each scheduled class section. (Meeting Attendance – Page 6) 
 

DAILY/SINGLE DAY ATTENDANCE ENTRY & SUBMISSION 

The Daily Attendance function is used to enter and submit student attendance for a single academic day. This function is 

used by the assigned classroom teacher, assigned co-teacher, and/or substitute teacher. Administrative users will not enter 

student attendance using the teacher’s Daily Attendance function. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 ATTENDANCE CODE DROPDOWN BOX 

 ATTENDANCE DATE 

 ATTENDANCE CODE ENTRY CELL 

 ATTENDANCE COMMENT ICON/ENTRY 

 SUBMIT STUDENT ATTENDANCE 

SUCCESSFUL ATTENDANCE 

SUBMISSION 

DAILY ATTENDANCE ENTRY/SUBMISSION PROCEDURES 

1. From the PowerTeacher Start Page > Click on the 

Chair (shown above)  

2. In the Date dropdown box > Verify the Date of 

Attendance prior to marking the students   

3. Attendance Code dropdown box > Select an 

attendance code   

 Blank = Present   

 2A = Unexcused Absent   

 1L = Excused Late   

 2L = Unexcused Late   

4. Marking the students > Click inside the 

attendance code cell/box to the right of the 

student’s name to mark students with the 

attendance code selected in step 3   

5. Attendance Comment > Click on the Attendance 

Comment Icon > Type the comment > Click 

Submit    

6. Repeat > The teacher will repeat steps 3-5 based 

on the actual/physical student attendance in 

his/her classroom   

7. Submit > Once all students have been coded 

appropriately the teacher will Click Submit   

8. Successful Submission > On the PowerTeacher 

Start Page a Green Circle indicates successful 

attendance submission   
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PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Entering & Submitting Attendance (continued) 

 

MULTI-DAY/PERIOD-MEETING ATTENDANCE ENTRY & SUBMISSION 

The Meeting/Period Attendance function is used to enter and submit student attendance for multiple academic days (as 

permitted by school administration). This function is to be used by the assigned classroom teacher, assigned co-teacher, 

and/or substitute teacher. Administrative users will not enter attendance using the PowerTeacher Multiday Attendance 

function.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

MEETING/PERIOD ATTENDANCE ENTRY/SUBMISSION PROCEDURES  

1. From the PowerTeacher Start Page > Click on the Table (shown above)    

2. In the Date Range box > Verify the Dates of Attendance > Click Edit to change the date range prior to attendance entry   

3. Attendance Code dropdown box > Select an attendance code   

 Blank = Present   

 2A = Unexcused Absent   

 1L = Excused Late   

 2L = Unexcused Late   

4. Marking the students > Click inside the attendance code cell/box to the right of the student’s name under the desired academic 

day to mark students with the attendance code selected in step 3   

5. Attendance Comment > Click Display > Click the Comment Icon > Type the comment > Click Submit    

6. Repeat > The teacher will repeat steps 3-5 to enter/modify student attendance for multiple academic days reflecting the 

physical/actual student attendance in his/her classroom   

7. Submit > Once all students have been coded appropriately for all dates the teacher will Click Submit   

8. Successful Submission > On the PowerTeacher Start Page a Green Circle indicates successful attendance submission 

ATTENDANCE CODE 

DROPDOWN BOX 
ATTENDANCE DATE RANGE 

DROPDOWN BOX 

ATTENDANCE COMMENT 

ENTRY + DISPLAY/HIDE 

SUCCESSFUL ATTENDANCE 

SUBMISSION 
GRAY ROW 

ATTENDANCE ENTRY/MODIFICATION 

UNAVAILABLE 

GREEN ROW 

CURRENT ACADEMIC DAY FOR 

ATTENDANCE ENTRY 

WHITE ROW 

ATTENDANCE ENTRY 

MODIFICATION AVAILABLE 

ATTENDANCE ENTRY 

SUBMISSION 

ATTENDANCE ENTRY 

SUBMISSION 
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PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Creating & Modifying the Class Seating Chart 

The Seating Chart is an optional PowerTeacher feature that is generally used by teachers for their substitute folders, and 

may be utilized to enter and submit Single Day Attendance. 

 

  CREATING A CLASS SEATING CHART 
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PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Creating & Modifying the Class Seating Chart (continued) 

 

Modifying or Deleting the Seating Chart Procedures                    

1. From the PowerTeacher Start Screen > Click on the Seating Chart Icon for the Course/Section    

2. Click on the Seating Chart Design Tab, then the Edit button   

3. In the Edit Layout Box the user may modify the Layout Name and Description (optional) > Click OK or Save As New   

4. To Delete the Seating Chart the user will Click Delete in the Edit Layout Box > Click Ok when prompted   

5. To Clear Students from the seating chart > Click Clear All   

6. To Move a Row/Group of Seats > highlight the row/group > once selection is orange move the seating to the desired 

location within the seating chart OR click Remove to remove the seats from the seating chart   

7. To Delete Seats and/or Objects > Click the Seat or Object > Click Remove   

8. The user may add, remove, or modify the following seats and objects within the seating chart:   

SEATS                              

 Rows:   Enter the number of Rows + Chairs per Row    

 Tables:   Enter the number of Tables desired + the number of Tables Across + Chairs per Table, the user can  

   create tables vertically or horizontally   

 Chairs:  Add Chairs (Seats) individually, one at a time   

OBJECTS                              

 Desk:  Teacher Desks/Teaching Areas    

 White-Board: Whiteboard/Front of Room   

 Door:  Classroom Entry + Emergency Exit   

 Text:  Label Desks/Classroom Areas   

9. Once the classroom/seating chart modifications are complete, the user can populate the students into  

the seats > Click Populate under Add Students > Add Students using the following options then Click Add:   

 Sort By:  Alphabetically, Alternating Male/Female, or Randomly assign students   

 Order:  Determines sort order A-Z or Z-A   

 Display:  Last Name or First Name   

 Start:  Where to begin Top Left/Right or Bottom Left/Right   

NOTE: 

If the user did not add enough seats to accommodate the class size, additional/individual seats will be shown unattached 

to the rows/tables created                         

10. Once the seating chart modifications are complete > Click Save    

11. Click on the Seating Chart tab to confirm the class seating chart or to take attendance 

NOTE: 

If the school has imported the student pictures, the student’s picture will populate on their assigned seat    
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PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Taking Attendance Using the Seating Chart 

The Seating Chart may be utilized to enter and submit Single Day Attendance. This function is to be used by the assigned 

classroom teacher, assigned co-teacher, and/or substitute teacher. Administrative users will not enter attendance using the 

PowerTeacher Seating Chart/Single Day Attendance function.  

 

SINGLE DAY/SEATING CHART ATTENDANCE ENTRY & SUBMISSION 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ATTENDANCE CODE 

DROPDOWN BOX 

ATTENDANCE ENTRY 

SUBMISSION 

ATTENDANCE DATE RANGE 

DROPDOWN BOX 

ATTENDANCE CODE ENTRY  

ATTENDANCE COMMENT 

ICON/ENTRY  

SINGLE DAY/SEATING CHART ATTENDANCE ENTRY/SUBMISSION PROCEDURES  

1. From the PowerTeacher Start Page > Click on the Chair + Table Icon (shown above)  

2. In the Date dropdown box > Verify the Date of Attendance prior to marking the students   

3. Attendance Code dropdown box > Select an attendance code   

 Blank = Present   

 2A = Unexcused Absent   

 1L = Excused Late   

 2L = Unexcused Late   

4. Marking the students > Click inside the attendance code cell/box on the upper-right of the student’s “seat/desk” to mark students 

with the attendance code selected in step 3 or selecting an attendance code in the dropdown box  

5. Attendance Comment > Click on the Attendance Comment Icon on the upper-left corner of the student’s “seat/desk” > Type the 

comment > Click Submit    

6. Repeat > The teacher will repeat steps 3-5 based on the actual/physical student attendance in his/her classroom   

7. Submit > Once all students have been coded appropriately the teacher will Click Submit   

8. Successful Submission > On the PowerTeacher Start Page a Green Circle indicates successful attendance submission   

SUCCESSFUL ATTENANCE 

SUBMISSION  
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PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Student Information/Individual Student Data 

Teachers will utilize the Student Information available to view individual data on students scheduled in their classes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ATTENDANCE COMMENT 

ICON/ENTRY  

SUCCESSFUL ATTENANCE 

SUBMISSION  
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PowerTeacher for HIGH SCHOOL YEARLONG COURSES: Print Class Reports 

Teachers will utilize the Print Class Reports feature to print Class Attendance Audits, Student Schedules, Attendance 

Summary for their students, etc… 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Printing Class Reports in PowerTeacher 

1. Click the Printer Icon from the PowerTeacher Start Page 

2. Select an Available Report from the 

 “Which report would you like to print,” Dropdown Box  

3. Click Submit 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  

Accessing & Navigating the PowerTeacher Pro Gradebook 

Teachers will navigate to the HTML-based gradebook directly through the teacher portal, using the PowerTeacher Pro link in 

either the Navigation Menu or from the Current Class list.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The first time the teacher logs into the PowerTeacher Pro Gradebook he/she will receive the Welcome to PowerTeacher Pro! 

Message. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: To View the Welcome Message again > Click the         Help Icon > Select Getting Started 

 Teachers can Open the PowerTeacher Pro 

Gradebook by Clicking the PowerTeacher Pro link 

in the Navigation Menu. 

 Teachers will use the Select Classes 

Menu/Dropdown Box at the top of the 

PowerTeacher Pro Screen to select the gradebook 

for the desired class or to switch from class to class 

in PowerTeacher Pro. 

 Teachers can Open the PowerTeacher Pro 

Gradebook for a specific class by Clicking the 

PowerTeacher Pro link in the Current Classes list. 

 The PowerTeacher Pro Gradebook will open for the 

selected class. Teachers will use the Select Classes 

Menu to switch between their gradebooks for their 

scheduled classes in PowerTeacher Pro. 

The Welcome to 

PowerTeacher 

Pro Welcome 

message will 

instruct teachers 

how to navigate 

in the gradebook 
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WARNING:  

 Teachers/Teachers of Record should not create additional assignment categories 

 Only the Pre-Defined Assignment Categories will be used to create assignments 

 Graduation Project: To be used by ONLY English III & English IV 

 Summative Performance: To be used by ONLY Spanish I & French I 

 SAE Project: To be used by ONLY Horticulture 

 A+ Grading Charm 

Contains Assignment List, Scoresheet, Categories, Traditional Grade functions, Comment Verification, Final Grade 

Status, etc… teachers will spend the majority of their time under the Grading App 

 Students Charm 

Contains student specific information regarding assignments, class progress, overall academic progress, etc… 

 Progress Charm 

Contains overall Class progress and data allowing teachers to view/compare grading trends and overall class 

performance term to term 

 Reports Charm 

Contains Individual Student, Multi-functional, Scoresheet, and Student Roster Reports 

 Settings Charm 

Contains the display preference settings for PowerTeacher Pro 

 Apps Charm 

Contains a link to the PowerTeacher Portal allowing teachers to view PowerTeacher information in a new 

tab/window 
 

 

 

 

 

 

PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: PowerTeacher Pro Charms 

PowerTeacher Pro uses Charms to reference different program sections that contain specific information and teacher 

functions.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Pre-Defined Assignment Categories 

The PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES has been setup with the following  

pre-defined Assignment Categories: Formal, Informal, Midterm Exam, Final Exam, Graduation Project, Summative 

Performance, SAE Project. There should be no additional Assignment Categories created, the Pre-Defined Assignment 

Categories are the only categories configured to calculate in the Final Grade-Traditional Grade Calculations. 

 

 

 

 

 

 

 
 
 

To View the Pre-Defined Assignment Categories  

1. Open the PowerTeacher Pro Gradebook 

2. Select Grading from the Menu Bar 

3. Select Categories from the Grading Menu 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Pre-defined Assignment Categories have the SCHOOL ICON in the Category Name 

column 

Any Assignment Categories created 

by a teacher will NOT have the 

School Icon in the Category Name 

column 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Additional Assignment Categories  

The PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES has been setup with Pre-Defined Assignment 

Categories: Formal, Informal, Midterm Exam, Final Exam, Graduation Project, Summative Performance, SAE Project. Any 

additional Assignment Category created by the teacher/teacher of record will NOT count in the Final Grade Calculation 

and will need to be set as an Inactive Assignment Category or Deleted.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

To Make an Additional Assignment Category Inactive or to Delete complete the following Instructions 

1. Open the PowerTeacher Pro Gradebook > Select Grading in the Menu Bar > Select Assignment List 

2. Identify any Assignment attached to the Additional Assignment Category > Click the Edit Icon for the assignment 

3. Change the Assignment Category to FORMAL or INFORMAL Categories, if it is not the Midterm or Final Exam (Midterm 

and Final Exams should be created and scored in the appropriate Assignment Category 

4. Click Save 

5. Repeat Steps 2-4 for any/all assignments attached to an Assignment Category other than the Pre-Defined Assignment 

Categories 

6. Select Grading in the Menu Bar > Select Categories 

7. Click the Edit Icon for the Additional Assignment Category:  

Make the Assignment Category Inactive OR Delete the Assignment Category: 

A. To Make Inactive: Click/Select the Circle next to Inactive > Click Save > The Category will not be displayed  

on the Assignment Category Screen (to Display the Inactive Category > Check the Box on 

the upper-right corner next to Show Inactive) 

B. To Delete:  Click Delete > Click Confirm Delete  
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Pre-Defined Final Grade-Traditional Calculations 

The Final Grade - Traditional Grade Calculations determine how the final grade for each reporting term is calculated.  The Final Grade-

Traditional Grade Calculations for HIGH SCHOOL YEARLONG COURSES have been pre-defined for the F1 (Final Grade), S1 (Semester 1), X1 

(Midterm Exam), S2 (Semester 2), & E1 (Final Exam) Terms in the PowerTeacher Pro Gradebook. The following courses have course specific 

Final Grade-Traditional Grade Calculations: English III, English IV, Spanish I, French I, Horticulture I, & Horticulture II.   

 

To View Pre-Defined Final Grade-Traditional Grade Calculations for HIGH SCHOOL YEARLONG COURSES 
1. Open the PowerTeacher Pro Gradebook  

2. Select Settings from the Menu Bar 

3. Select Traditional Grade Calculations from the Settings Menu 

4. Click the Edit Icon           in the Actions column to View the Pre-Defined Grade Setup for each of the Pre-Defined Terms for each 

class (see the F1 Reporting Term screen shot below) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Teachers/Teachers of Record are required to setup the Final Grade-Traditional Grade Calculations for all HIGH SCHOOL 

YEARLONG COURSES as instructed.  Pre-Defined Calculations may not be altered. Upon completion Teachers are required to 

complete the “Final Grade-Traditional Grade Calculations Setup & Assignment Categories Verification Form” (Found on 

Page 51 of this Guide). Teachers are required to obtain the signature of the PowerTeacher Pro Gradebook Trainer and have 

them review their Gradebook to ensure that the Final Grade Setups have been entered/setup correctly and that no 

additional Assignment Categories have not been created.  

 

HIGH SCHOOL YEARLONG ENGLISH III & ENGLISH IV  ADVANCE TO PAGE 18 

HIGH SCHOOL YEARLONG SPANISH I & FRENCH I   ADVANCE TO PAGE 19 

HIGH SCHOOL YEARLONG HORTICULTURE I & HORTICULTURE II ADVANCE TO PAGE 20 

 

HIGH SCHOOL  

YEARLONG COURSES 

F1 Pre-Defined  

Traditional Grade Calculation 

Screen Shot 

NOTE:  

Pre-Defined Traditional Grade Calculations CAN NOT be Modified  

CPCC, UNCC, VPS, & ONLINE FINAL GRADE CALCULATION SETUPS  

ARE PROVIDED IN THE  

CPCC, UNCC, & ONLINE 18 WEEK & 36 WEEK TRAINING/SUPPORT GUIDES   

AND CONTAIN SPECIFIC GRADEBOOK SETUP & GRADING INSTRUCTIONS. 
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REQUIRED FINAL GRADE CALCULATION SETUP: HIGH SCHOOL YEARLONG (36 WEEK) COURSES 

Teachers will setup the required Traditional Grade Calculations for Q1, Q2, Q3, and Q4 for all Yearlong (36 Week) Classes as 

instructed below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

QUARTER 1 (Q1), QUARTER 2 (Q2), QUARTER 3 (Q3), & QUARTER 4 (Q4): Traditional Grade Calculation Setup Instructions 

 

 

 

 

 

 

  

 

 

 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A 
 B 

 

To Select a Class Teachers can utilize one of the following 

options: 

A: Use the Select Classes Menu/Dropdown Box at the 

top of the PowerTeacher Pro screen and Click on 

the Class link 

B: From the Traditional Grade Calculations Screen 

Click the triangle to the LEFT of the Class 

Expression/Name to expand the Traditional Grade 

Calculations for the class 
 

1. After Selecting the class Click on the 

triangle to the LEFT of the Class 

Expression/Name to Open/Expand the 

Traditional Grade Calculations Window 

2. Click the Edit Icon          in the Actions 

Column for Q1 

3. TYPE Dropdown Box: Select CATEGORY 

WEIGHTING 

4. ATTRIBUTE Dropdown Box: Select FORMAL 

5. WEIGHT: Enter 70 in the field 

6. Click the Add Icon 

7. TYPE Dropdown Box:  

Select CATEGORY WEIGHTING 

8. ATTRIBUTE Dropdown Box:  

Select INFORMAL 

9. WEIGHT: Enter 30 in the field 

10. Click Save 

11. REPEAT STEPS 2-10 FOR QUARTER 2 

12. REPEAT STEPS 2-10 FOR QUARTER 3 

13. REPEAT STEPS 2-10 FOR QUARTER 4 

 

After the Final Grade Calculation for Q1, Q2, 

Q3, and Q4 have been setup the Traditional 

Grade Calculations screen for the Class 

should NOT have ANY Reporting Terms with 

Total Points as the Formula Type). See  

 

 

 
 

HIGH SCHOOL YEARLONG COURSES 

TRADITIONAL GRADE CALCULATION SCREEN   

AFTER THE Q1, Q2, Q3, & Q4 SETUPS  

HAVE BEEN ENTERED 
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REQUIRED FINAL GRADE CALCULATION SETUP: HIGH SCHOOL YEARLONG ENGLISH III & ENGLISH IV 

Only the English III and English IV teachers will use the GRADUATION PROJECT Assignment Category. Users are required to 

setup the Yearlong English III and English IV Final Grade Calculations for Q1, Q2, Q3, & Q4. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. From the PowerTeacher Start Page > Open 

the PowerTeacher Pro Gradebook > Select 

Settings from the Menu Bar > Select 

Traditional Grade Calculations 

2. After Selecting the class Click on the triangle 

to the LEFT of the Class Expression/Name to 

Open/Expand the Traditional Grade 

Calculations Window 

3. Click the Edit Icon           in the Actions 

Column for Q1 

4. TYPE Dropdown Box: Select CATEGORY 

WEIGHTING 

5. ATTRIBUTE Dropdown Box: Select FORMAL 

6. WEIGHT: Enter 70 in the field 

7. Click the Add Icon 

8. TYPE Dropdown Box:  

9. Select CATEGORY WEIGHTING 

10. ATTRIBUTE Dropdown Box:  

11. Select INFORMAL 

12. WEIGHT: Enter 30 in the field 

13. Click Save 

14. REPEAT STEPS 2-12 FOR QUARTER 2 

15. REPEAT STEPS 2-12 FOR QUARTER 3 

16. Click the Edit Icon          in the Actions 

Column for Q4 

17. TYPE Dropdown Box: Select CATEGORY 

WEIGHTING 

18. ATTRIBUTE Dropdown Box: Select FORMAL 

19. WEIGHT: Enter 40 in the field 

20. Click the Add Icon 

21. TYPE Dropdown Box:  

22. Select CATEGORY WEIGHTING 

23. ATTRIBUTE Dropdown Box:  

24. Select INFORMAL 

25. WEIGHT: Enter 20 in the field 

26. Click the Add Icon 

27. TYPE Dropdown Box:  

28. Select CATEGORY WEIGHTING 

29. ATTRIBUTE Dropdown Box:  

30. Select Graduation Project 

31. WEIGHT: Enter 40 in the field 

32. Click Save 

 



PowerTeacher & PowerTeacher Pro Gradebook 
SUPPORT/TRAINING GUIDE FOR HIGH SCHOOL YEARLONG COURSES 

 
 

Page | 19 

CMS PowerTeacher/PowerTeacher Pro Gradebook  

 

 

REQUIRED FINAL GRADE CALCULATION SETUP: HIGH SCHOOL YEARLONG SPANISH I & FRENCH 1 

Only the Spanish 1 and French I teachers will use the SUMMATIVE PERFORMANCE Assignment Category. Users are required to 

setup the Yearlong Spanish I and French I Final Grade Calculations for: F1, Q1, Q2, S1, X1, Q3, Q4, S2, & E1.  
 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Select Settings in the Menu Bar 

2.  Select Traditional Grade Calculations 

3. One the Traditional Grade Calculations Screen Click on the triangle to the LEFT of the Spanish I/French I Class (yearlong 18-19) to Open/Expand the 

Traditional Grade Calculations Window 

4. Setup/Enter the following Final Grade Calculations for each section of 18-19 Spanish I/French I: 

F1: Final Grade Calculations  
Click the Edit Icon in the Actions Column for F1 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  S1  
 Weight:   40 

Click the Add Icon 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  S2 

 Weight:   40 

Click the Add Icon 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  E1 

 Weight:   20 

Click Save  
 

S!: Final Grade Calculations  
Click the Edit Icon in the Actions Column for S1 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  Q1 

 Weight:   40 

Click the Add Icon 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  Q2 

 Weight:   40 

Click the Add Icon 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  X1 

 Weight:   20 

Click Save 
 

S2: Final Grade Calculations  
Click the Edit Icon in the Actions Column for S2 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  Q3  
 Weight:   50  
Click the Add Icon 

 Type Dropdown Box:   Select Term Weighting 

 Attribute Dropdown Box:  Q4 

 Weight:   50 

Click Save 
 

Q1, Q2, Q3: Final Grade Calculations  
Click the Edit Icon in the Actions Column for Q1  
 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box:  Formal 

 Weight:   70 

Click the Add Icon 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box:  Informal 

 Weight:   30 

Click Save 

REPEAT THE EXACT SAME SETUPS FOR: Q2 AND Q3 

Q4: Final Grade Calculations  
Click the Edit Icon in the Actions Column for Q4 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box:  Formal 

 Weight:   30 

Click the Add Icon 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box:  Informal 

 Weight:   20 

Click the Add Icon 

 Type Dropdown Box:  Select Category Weighting  
 Attribute Dropdown Box:  Summative Performance 

 Weight:   50 

Click Save 

X1 & E1: Final Grade Calculations  
Click the Edit Icon in the Actions Column for X1 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box:  Midterm Exam 

 Weight:   100 

Click Save 

Click the Edit Icon in the Actins Column for E1 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box:  Final Exam 

 Weight:   100 

Click Save  
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REQUIRED FINAL GRADE CALCULATION SETUP: HIGH SCHOOL YEARLONG HORTICULTURE I & HORTICULTURE II 

Only the Horticulture I & Horticulture II teachers will use the SAE PROJECT Assignment Category. Users are required to setup 

the Yearlong Horticulture I & Horticulture II Final Grade Calculations for: Q1, Q2, Q3, & Q4.  
 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook 

2. Select Settings in the Menu Bar > Select Traditional Grade Calculations 

3. One the Traditional Grade Calculations Screen Click on the triangle to the LEFT of the Horticulture I/Horticulture II Class (yearlong 18-19) 

to Open/Expand the Traditional Grade Calculations Window 

4. Setup/Enter the following Final Grade Calculations for each section of 18-19 Horticulture I/Horticulture II: 
 

Q1: Final Grade Calculations  
Click the Edit Icon in the Actions Column for Q1  
 Type Dropdown Box:  Select Category Weighting 

 Attribute Dropdown Box: Formal 

 Weight:   70 

Click the Add Icon 

 Type Dropdown Box:  Select Category Weighting 

 Attribute Dropdown Box: Informal 

 Weight:   30 

Click Save 

 

 

 

Q2: Final Grade Calculations  
Click the Edit Icon in the Actions Column for Q2  
 Type Dropdown Box:  Select Category Weighting 

 Attribute Dropdown Box: Formal 

 Weight:   70 

Click the Add Icon 

 Type Dropdown Box:  Select Category Weighting 

 Attribute Dropdown Box: Informal 

 Weight:   30  
 

 

 

Q3: Final Grade Calculations  
Click the Edit Icon in the Actions Column for Q3  
 Type Dropdown Box:  Select Category Weighting 

 Attribute Dropdown Box: Formal 

 Weight:   70 

Click the Add Icon 

 Type Dropdown Box:  Select Category Weighting 

 Attribute Dropdown Box: Informal 

 Weight:   30 

Click Save 

 

 

 

 Q4: Final Grade Calculations  
Click the Edit Icon in the Actions Column for Q4  
 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box: Formal 

 Weight:   50 

Click the Add Icon 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box: Informal 

 Weight:   20 

Click the Add Icon 

 Type Dropdown Box:   Select Category Weighting 

 Attribute Dropdown Box: SAE Project 

 Weight:   30 

Click Save 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: 

Customizing Class Names and Adding Class Descriptions (optional) 

Teachers can customize the class name for currently assigned course sections, if the teacher prefers to use a name that is 

different from the course name. For example, if the teacher is assigned multiple sections of Physical Education, they may 

customize the class names to be different from each other. Custom class names appear only in the gradebook  

(Co-teachers, students, & parents will not see customized class names). Teachers may also add details about the class, such 

as a Class Description or syllabus that will be visible in the PowerSchool Student and Parent Portals, and on the PowerSchool 

Mobile App. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Procedures to Customize a Class Name or Add a Class Description 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Verify the desired Class is selected in the 

PowerTeacher Pro Gradebook OR Click the Class Link for the desired Class in the Select Classes Menu/Dropdown Box  

2. Select Settings from the Menu Bar > Select Class Descriptions 

3. On the Class Descriptions Screen > Enter the Custom Class Name and/or Class Description 

4. Click Save 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Display Preferences 

Teacher can customize display settings to control how class appear in their gradebook (by period and day or by section 

number), how students are sorted/listed in the gradebook, how students’ names appear, and more.  
 

 

 

 

 

 

 
 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

 
 

 
 
 

 
 

Display Preference    Available Settings/Features 
Display and Sorting    Select the desired Class List Sort option for the gradebook display 

 Period/Day 

 Section Number (Number) 

 Section Number (Course/Custom Name) 

Show Traditional Grades    CHECK THE BOX to display traditional grades in the gradebook 

Values to Show in the Traditional Grade Column Define/Select what grades are seen in the gradebook 

 Grade 

 Percent 

 Point Grades 

Show Standards Page and Links   DO NOT CHECK – STANDARDS GRADING IS CURRENTLY UNAVAILABLE 

Student Name     Define how the students’ names display in the gradebook 

 Last, First   Example: Smith, John 

 Last, First M.   Example: Smith, John T. 

 Last, First Middle   Example: Smith, John Taylor 

 First Last   Example: John Smith 

 First M. Last   Example: John T. Smith 

 First Middle Last   Example: John Taylor Smith 

Sort Students By     Define how students will be soerted in the gradebook/ class list 

 Last Name   Alpha Order by Last Name 

 First Name   Alpha Order by First Name 

 Grade Level then Last Name Grade Level in Alpha Order by Last Name 

 Grade Level then First Name Grade Level in Alpha Order by First Name 

Add newly enrolled students to the bottom Select this option to have newly enrolled students populate at the bottom of the 

gradebook/class list upon enrollment 

Hide pre-registered students Select this option to hide pre-registered students prior to their entry date 

 

Display Preference Setup Procedures 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Select Settings from the Menu Bar 

2. Select Display Settings from the Settings Menu 

3. Select the desired Display Settings/Preferences (see Display Preferences/Settings & descriptions above) 

4. Click Save 
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WARNING:  

 Teachers/Teachers of Record should not create additional assignment categories 

Only the Pre-Defined Assignment Categories will be used to create assignments 

Graduation Project: To be used by ONLY English III & English IV 

 Summative Performance: To be used by ONLY Spanish I & French I 

 SAE Project: To be used by ONLY Horticulture I & Horticulture II 

 

PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Changing the Display Text Size 

Teachers may choose to modify the text/font size displayed in the PowerTeacher Pro gradebook as desired. 
 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Creating and Viewing Assignments 

The PowerTeacher Pro Gradebook for High School Yearlong Courses have been setup with Pre-Defined Assignment 

Categories: Formal, Informal, Midterm Exam, Final Exam, Graduation Project, Summative Performance, & SAE Project. Only 

The Pre-Defined Assignment Categories are configured to count in the Final Grade-Traditional Grade Calculations. Users 

should not create any additional Assignment Categories or create assignments under additional Assignment Categories. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To change the text/font size displayed the teacher will 

follow the steps listed below, in the PowerTeacher Pro 

Gradebook: 

1. From the PowerTeacher Start Page > Open the 

PowerTeacher Pro Gradebook 

2. The teacher will Click on his/her Name in the upper-right 

corner of the PowerTeacher Pro Gradebook 

3. In the dropdown box under VIEW > Select the desired 

text/font size to display in the PowerTeacher Pro 

gradebook: 

A.Small To Select > Click on Small 

B. Medium To Select > Click on Medium 

C.Large To Select > Click on Large 

4. The text/font size will automatically change on the 

screen and the dropdown box will close 
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Creating an Assignment 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

How to Create an Assignment in the PowerTeacher Pro 

Gradebook 

1. From the PowerTeacher Start Page > Open the PowerTeacher 

Pro Gradebook > Click Create > Select Assignment 

2. Assignment Tab: 
A. Classes  

 Teachers will choose to create the assignment for one or more classes 

by Checking/Selecting the class(es) on the Select Classes Menu > 

Once all classes have been selected > Click outside the menu box to 

Close the Select Classes Menu 

B. Assignment Name  

 Enter the Name of the Assignment 

C. Category  

 Teachers will Select the Assignment Category in the Select Category 

dropdown box: 

 FORMAL To Select > Click Formal 

 INFORMAL To Select > Click Informal 

D. Score Type  

 Teachers will select how the assignment will scored/graded in the 

Score Type dropdown box: 

 POINTS  Used to grade assignments with a specific point  

  value. Utilized by the teacher if Extra Credit/Bonus  

  Points will be awarded. 

   EXAMPLE: Homework/Wk 1= 10+5 ExtraPoints 

         15 Max Points 

   Suzy scores 9 Points on HW Assignments+5 Extra  

  Points. The teacher will enter a 14 in the gradebook. 
 

 PERCENT Used by teachers who will calculate the assignment  

  percentage before entering the score/grade in the  

  gradebook/scoresheet. 

   EXAMPLE: Unit 1 Test= 100 Max Points 

   Suzy scores 90/100 on the Unit 1 Test. The teacher will  

  enter a score/grade of 90 for the assignment in the  

  gradebook/scoresheet. 
 

 LETTER(100-F) NC 10-Point Grade Scale will not allow letter grades  

  on assignments  

 COLLECTED Used by teachers to collect required assignments, 

 ONLY  forms, and or documents with NO point value. 

   EXAMPLE: Signed/Returned Progress 

   Suzy returned her 3rd Qtr Progress Report. The teacher 

  will verify the assignment was collected in the  

  gradebook/scoresheet. 

E. Count in Final Verify the Count in Final Grade is Selected 

Grade Box 

F. Due Date The default due date is the current date > The  

  teacher will change the due date assigned for the  

  assignment 

G.  Description The teacher can enter an assignment description  

  that will be seen on the PowerSchool Student &  

  Parent Portals. 

3. Click Save > Click the Students Tab (continue to the next page) 
  

  

   

   

CHECK THIS BOX TO SELECT 

OR DESELECT ALL STUDENTS 

CHECK THIS BOX TO SELECT 

OR DESELECT  

INDIVIDUAL STUDENTS 

CLICK ADD/REMOVE STUDENTS 
TO CREATE AN ASSIGNMENT FOR A 

SPECIFIC STUDENT GROUP 
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Creating an Assignment (continued) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

How To Create an Assignment in the PowerTeacher Pro Gradebook (continued) 

4. Students Tab > Verify that the assignment applies to all students (by default all students are included) 

Teachers may Create a Student Selection for a specific:  

A.To apply an assignment to a specific student selection > Click Add/Remove Students > Uncheck the students who will not be 

included in the assignment (by default all are checked/selected) 

B. To apply an assignment to a specific student or a limited student selection > Click Add/Remove Students > Uncheck the box 

on the top right next to the Filter area/cell to clear all students from the selection > Select the student(s) included in the 

assignment by checking the box next to the students’ names 

5. Click the Publish Tab: 

A. The teacher will select one of the available publishing options to choose when the assignment and assignment 

scores/grades will be published to the PowerSchool Student and Parent Portals: 

 Immediately  Upon creating the assignment 

 On Specific Date  The teacher will enter the desired publish date in the Publish Date box 

 Days Before Due Date The teacher will enter the number of days prior to the due date for the assignment that the 

    assignment will be published in the Days Before Due Date box 

 On Due Date  The assignment will publish on the due date for the specific assignment 

 Never   The teacher will utilize the NEVER publish option for assignments that do not require  

    publishing/viewing 

B. Publish Scores  The Publish Scores is checked/selected by Default    

    Teachers may Publish an Assignment without publishing the scores. 

    The teacher will uncheck the Publish Scores box if scores they want to publish the  

    assignment and wait to publish the scores until all grades/scores for the assignment have 

    been entered  

6. Click Save and Close  
  

   

NOTE 

TO SCORE THE ASSIGNMENT IMMEDIATELY > CLICK SCORE ASSIGNMENT IN THE SUCCESSFUL 

ALERT/NOTIFICATION AT THE TOP OF THE SCREEN/WINDOW TO OPEN THE ASSIGNMENT SCORESHEET 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  

Editing/Modifying and Deleting an Assignment 

Teachers may need to edit/modify or delete an assignment from the gradebook throughout the year. It is important to remember 

that if an assignment was COPIED it should not be deleted as the assignment will be deleted from all classes. If teachers no longer 

want an assignment to count in the Final Grade for the Term they will want to modify the assignment as instructed below. 

Assignments can be edited from the Assignments List or Scoresheet in the PowerTeacher Pro Gradebook. 

 

   

 

  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

Procedures for Editing/Modifying, Excluding the Term Final Grade, 

or Deleting an Assignment 

1. From the PowerTeacher Start Page > Open the PowerTeacher 

Pro Gradebook > Select the desired Class by Clicking the Class 

Link or Verify the desired Class is selected in the Select Classes 

Menu/Dropdown Box at the top of the screen 

2. Verify the Term containing the assignment to be edited/modified 

or deleted is selected in the Term Menu 

3. Select Grading from the Menu Bar > Select Assignment List OR 

Scoresheet 

4. Open the Edit Assignment box: 

A.From the Assignment List > Click the Edit Icon for the specific 

assignment 

B. From the Scoresheet > Navigate within the Scoresheet to 

locate the Assignment/Assignment Column > Click inside the 

score/grade cell for a student in the Assignment Column > The 

assignment information will be displayed at the top of the 

screen > Click the Edit Assignment link 

5. Make and/all Assignment Modifications, Exclude from the Final 

Grade for the Term, or Delete the Assignment following the 

instructions below: 

A.On the Assignment Tab 
 Edit/Modify 

 Modifications/Edits can be made to the Assignment Name, Score 

 Type, Score Entry Points, Add/Remove Extra Points, Add/Remove 

 assignment Weights, Due Date, and/or Description 

 Click Save and Close once all desired assignment 

 edits/modifications have been made OR Click the Students or 

 Publish Tabs to make additional modifications 

 To DELETE the Assignment 
Click Delete on the bottom-left corner > Click Confirm Delete 

WARNING! DO NOT DELETE A COPIED ASSIGNMENT: 

To remove a COPIED Assignment from a specific class > UNCHECK 

the Count in Final Grade Box > In the Select Classes Menu UNCHECK 

the Class > Click Save and Close 

B. On the Students Tab 

 Click Add/Remove Students to modify the student selection 

 Click Save and Close OR Click the Publish Tab to make additional 

 modifications 

C. On the Publish Tab 

 Check the Publish Scores to publish the scores/grades on a 

 specific assignment OR Edit/Modify the Publish Assignments option 

 as desired 

6. Click Save and Close 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: 

Duplicating an Assignment for Use in the Same Class or for Use in Another Class 

Teachers who have a reoccurring weekly or quarterly assignment or those who use the same assignments in multiple classes 

may choose to utilize the Duplicate Assignment feature. Assignments can be Duplicated from the Assignment List or 

Scoresheet in the PowerTeacher Pro Gradebook. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Procedures to Duplicate an Assignment 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Select the desired Class by Clicking the Class Link 

or Verify the desired Class is selected in the Select Classes Menu/Dropdown Box at the top of the screen 

2. Verify the Term containing the assignment to be edited/modified or deleted is selected in the Term Menu 

3. Select Grading from the Menu Bar > Select Assignment List OR Scoresheet 

4. Open the Edit Assignment box 

A.From the Assignment List > Click the Edit Icon for the specific assignment 

B. From the Scoresheet > Navigate within the Scoresheet to locate the Assignment/Assignment Column > Click inside the 

score/grade cell for a student in the Assignment Column > The assignment information will be displayed at the top of  

the screen > Click the Edit Assignment link 

5. Click Duplicate on the bottom of the Edit Assignment box 

6. In the Create: Assignment Box on the Assignment Tab > Select the Class/Classes to Assign the Duplicate Assignment from the 

Select Classes Menu > Check the box next to the class/classes to select  

7. UNCHECK/DESELECT the Currently Selected Class to not duplicate the assignment in the gradebook 

TO DUPLICATE AN ASSIGNMENT FOR THE INDIVIDUAL CLASS 

 Click Duplicate on the bottom of the Edit Assignment box 

 Select Classes Menu > DO NOT Uncheck the Class and DO NOT select other classes 

8. In the Create: Assignment Box on the Assignment Tab 

 Edit/Modify the Assignment Name > Delete the Underscore and Number that were appended to the end of the Assignment 

 Name when the assignment was duplicated > the teacher can choose one of the following options: 

A. To use the same Assignment Preferences/Specifications, Student Preferences, & Publish Options as the original 

B. Make modifications to the Assignment Name, Category, Score Type, Points, Due Date, etc… 

9. Click Save and Close 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Copying an Assignment 

Teachers may Copy one, some, or all of the existing PowerTeacher Pro Assignment in a selected term and class to other 

terms and classes using the Copy Assignments feature. Teachers may choose to use the existing due dates, select a custom 

due date, or the relative (Relational) due date proportional to the selected term. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE 

It is important 

for teachers to 

remember to 

EDIT the DUE 

DATES of the 

Copied 

Assignments 

 

WARNING:  

DO NOT DELETE COPIED ASSIGNMENTS 

DELETING A COPIED ASSIGNMENT FROM ONE 

CLASS WILL DELETE THE ASSIGNMENT FROM ALL 

CLASSES! 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Navigating the Scoresheet 

The PowerTeacher Pro Gradebook offers teachers two types of Scoresheets, the Assignment Scoresheet and the Term 

Scoresheet. The Assignment Scoresheet will display the Scoresheet for an individual/specific assignment. The Term 

Scoresheet will display all assignments for the selected term.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

TERM SCORESHEET 

NAVIGATION: PowerTeacher Teacher > PowerTeacher Pro Gradebook > Grading > Scoresheet 

CONTAINS ALL ASSIGNMENTS FOR THE SELECTED TERM 
 

SELECT CLASSES 

 MENU/DROPDOWN BOX 
Switch between Class Gradebooks  

SCORESHEET PAGE NAVIGATION 
Use the Page OR Arrow Navigation Options to 

view all term assignments or locate the 

desired assignment column to enter 

scores/grades 

ASSIGNMENT COLUMN 
Double Click on the Assignment Name 

to Open the Assignment Scoresheet 

 

SCORE INSPECTOR 
Used to Enter 

Assignment 

Score/Grade Details 

regarding students’ 

performance for a 

specific assignment 

ASSIGNMENT INFORMATION/SUMMARY 
Teachers will review the Score Type & Max Points on the assignment 

to ensure proper entry OR Open the Edit Assignment Screen/Box to 

Edit assignment details 

SCORE/GRADE CELL 
Click Inside a 

Score/Grade Cell To 

OPEN the Score 

Inspector OR 

Entering (typing) the 

Assignment 

Scores/Grades 

TERM MENU  
Teachers will use the Term Menu to 

switch between quarterly/term 

gradebooks

CREATE > ASSIGNMENT 

COMMENT BANK 
Click to enter an APPROVED 

Comment on a specific 

assignment for a student or class 

STUDENT NAVIGATION 

Move from Student to Student  

GEAR = TOOLS 
Scoresheet  

Tools & Functions 

CLASS LIST 

EDIT ASSIGNMENT LINK 

ENTER HOW 

MANY 

COLUMNS TO 

VIEW ON A 

PAGE 

SAVE 

SCORES/GRADES 

OR 
MODIFICATIONS 

TERM 

FINAL GRADE 

CALCULATION 

COLUMNS 
% + Grade 

ASSIGNMENT NAVIGATION 

Move from Assignment to 

Assignment  

 

ASSIGNMENT SCORESHEET NAVIGATION 
 

NAVIGATION: 

 PowerTeacher Teacher > PowerTeacher Pro Gradebook  

 Grading > Assignment List > Click the Assignment Link 

 

CONTAINS THE SCORESHEET FOR AN 

INDIVIDUAL/SPECIFIC ASSIGNMENT SELECTED 

 

THE ASSIGNMENT SCORESHEET FUNCTIONS THE SAME 

AS THE TERM SCORESHEET 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Entering Assignment Scores/Grades 

Teachers can enter Assignment Scores/Grades from the Assignment List or Scoresheet in the PowerTeacher Pro Gradebook. 

When entering assignment scores/grades, teachers will need to ensure that the scores/grades being entered MATCH the 

Score Type of the assignment, and that the maximum score being entered does not exceed the Score Entry 

Points/Maximum Score for the assignment.  

 

Entering Assignment Scores/Grades: From the Assignment List 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Assignment Score Type/Max Points 

 It is extremely important that teachers enter scores/grades 

matching that of the Assignment Score Type & Max Point Value 

 Teachers will ensure that the correct score type/point values 

are entered by reviewing the Assignment Information at the top 

of the screen 

 Extra Points must be added/created to enter a score/grade 

higher than the Score Entry Points/Max Points Possible 

 To Edit the Assignment or to Add Extra Points/Bonus Points, 

teachers can Click the Edit Assignment link in upper-right 

corner of the Assignment Information and make modifications 

to the assignment 

When Selecting ASSIGNMENT LIST from the Grading 

Menu 

 Verify that the Term containing the Assignment to be 

Graded is Selected in the Term Menu 
 

 Locate the Assignment in the Assignments List 
 

 Click the ASSIGNMENT NAME to OPEN the Assignment 

Scoresheet for the Selected/Individual Assignment 

 

 

 

 

 

 

Entering Scores/Grades 

 In order to Enter the Assignment Scores/Grades teachers will Click in the 

Score/Grade Cell for a student >  

 Teachers may Enter the Assignment Scores/Grades using the Score Inspector or 

manually entering/typing the scores/grades  

 On the Computer Keyboard teachers will use the arrows to move from student to 

student on the Scoresheet 

 Using the Score Inspector, teachers will use the Student Navigation to move from 

student to student 

 The teacher will also enter any Indicator Flags and/or Comments using the Score 

Inspector 

 Click Save Scores once all Scores/Grades, Indicator Flags, & Comments have been 

entered for the assignment 

SHOW ASSIGNMENT METRICS FEATURE 
 Click the GEAR Icon on the upper-right corner of the Scoresheet > Click Show Metrics 

 The Assignment Metrics will be displayed under the Assignment Name and 

Assignment Score Type/Max Score on the top of the screen 

 The Assignment Metrics provide the teacher with the overall class performance on 

the specific assignment by displaying the Mean, Median, & Mode: 

Mean:  The mathematical average of the assignment scores 

Median:  The middle of the scores (half of the scores are above this number  

  and half are below) 

Mode:  The most common score achieved 

 The Metrics allow teachers to develop teaching strategies/instructional lesson plans, 

evaluate the success of the specific lesson/assignment, and the students’ retention 

of the content/subject curriculum associated with the assignment   

 

 

  

 

 

 

 

NOTE: 

To Hide the Assignment Metrics 
 Click the GEAR Icon on the upper-right 

corner of the Scoresheet > Click Hide 

Metrics 

 The Assignment Metrics will no longer 

be displayed on the Scoresheet 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Entering Assignment Scores/Grades (continued) 

 

Entering Assignment Scores/Grades: From the Scoresheet 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When Selecting SCORESHEET from the Grading Menu 
 Verify that the Term containing the Assignment to be Graded is Selected in the Term Menu on 

the upper-right corner of the screen 
 

 Locate the Assignment/Assignment Column to be graded in the Scoresheet using the 

Scoresheet Navigation options 
 

 Click Inside the score/grade cell for a student under the Assignment Column 

Assignment Score Type/Max Points 
 It is extremely important that teachers enter scores/grades 

matching that of the Assignment Score Type & Max Point 

Value 

 Teachers will ensure that the correct score type/point values 

are entered by reviewing the Assignment Information at the 

top of the screen 

 Extra Points must be added/created to enter a score/grade 

higher than the Score Entry Points/Max Points Possible 

 To Edit the Assignment or to Add Extra Points/Bonus Points, 

teachers can Click the Edit Assignment link in upper-right 

corner of the Assignment Information and make 

modifications to the assignment 

Entering Scores/Grades 
 In order to Enter the assignment Scores/Grades teachers will Click in the 

Score/Grade Cell for a student >  

 Teachers may Enter the assignment Scores/Grades using the Score Inspector or 

manually entering/typing the scores/grades  

 On the computer keyboard teachers will use the directional arrows to move from 

student to student on the Scoresheet 

 Using the Score Inspector, teachers will use the Student Navigation to move from 

student to student 

 The teacher will also enter any Indicator Flags and/or Comments using the Score 

Inspector 

 Click Save Scores once all Scores/Grades, Indicator Flags, & Comments have been 

entered for the assignment 

SHOW ASSIGNMENT METRICS FEATURE 
 Click the GEAR Icon on the upper-right corner of the Scoresheet  

  Click Show Metrics 

 The Assignment Metrics will be displayed under the Assignment Name and 

Assignment Score Type/Max Score on the top of the screen 

 The Assignment Metrics provide the teacher with the overall class performance on 

the specific assignment by displaying the Mean, Median, & Mode: 

Mean:  The mathematical average of the assignment scores 

Median:  The middle of the scores (half of the scores are above this number  

  and half are below) 

Mode:  The most common score achieved 

 The Metrics allow teachers to develop teaching strategies/instructional lesson plans, 

evaluate the success of the specific lesson/assignment, and the students’ retention 

of the content/subject curriculum associated with the assignment   

 

 

 

 

 

 

 

 

 

NOTE: 

To Hide the Assignment Metrics 
 Click the GEAR Icon on the upper-

right corner of the Scoresheet > Click 

Hide Metrics 

 The Assignment Metrics will no longer 

be displayed on the Scoresheet 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Using the Score Inspector & Indicator Flags 

The Score Inspector and Indicator Flags are used to provide details about a student’s performance including but not limited 

to: Missing, Late, Incomplete, Collected, and/or Exempt Assignment as well as assignments missed due to absence. The 

Score Inspector provides teachers with an option to enter a comment regarding a student’s performance and or 

score/grade for a specific assignment as desired using the Comment Bank or entering/typing a brief (30 characters max) 

comment in the comment box. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

COMMENT BANK 

ICON 

CLOSE 

THE SCORE INSPECTOR 

SCORE INSPECTOR 

COMMENT BOX 

FLAGS 

CODES 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  

Adding Comments for an Individual Student 

As teachers enter scores/grades and/or indicator flags they can utilize the Comment Feature to record specific details 

regarding an individual student’s score/grade and/or performance on an assignment, text, project, etc… Comments can 

be selected from the Comment Bank or typed.  

 

 

 

 

     

 

 

 

 

 

 

 

 

 

 

 

 

Adding/Entering an Assignment Comment Using the Score Inspector 

1. From the Assignment Scoresheet or Term Scoresheet > Click inside the student’s score/grade cell to Open the Score 

Inspector 

2. Click the Comment Bank Icon in the upper-right corner of the Score Inspector to Open the Comment Bank > Select a 

comment from the list provided 

3. Enter/Type a brief comment in the Comment Box on the bottom of the Score Inspector (30 characters max) 

4. Click Save Scores 

NOTE: A Blue Comment Icon will be displayed in the upper-right corner of the student’s score/grade cell 

 

Viewing/Editing an Assignment Comment Using the Score Inspector 

1. From the Assignment Scoresheet or Term Scoresheet > Click inside the student’s score/grade cell to Open the Score 

Inspector 

2. Click the Blue Comment Icon in the upper-right corner of the score/grade cell 

3. The Comment can be viewed in the Comment Box at the bottom of the Score Inspector 

4. The Comment can be modified by deleting or editing the comment in the Comment Box at the bottom of the Score 

Inspector or Selecting a comment from the Comment Bank > Click Save Scores once the assignment comment has been 

modified 

5. Close the Score Inspector or navigate to another student to view and/or modify their assignment comment 

 

 

 

 

WARNING! 

 COMMENTS HAVE A 30 CHARACTER MAXIMUM  

 TEACHERS ENTERING/TYPING AN ASSIGNMENT COMMENT WILL NEED TO KEEP COMMENTS BRIEF – NO LONGER THAN 30 CHARACTERS MAXIMUM.  

 

 

 

ENTER/TYPE A 

COMMENT 

SELECT A 

COMMENT 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Filling Scores/Grades 

Teachers will utilize the Fill Functions to either Fill Scores/Grades for one assignment for all students in the class, or to fill an 

assignment score/grade for multiple assignments for an individual student. Scores/Grades can be filled for assignment 

scores/grades that do not already have a score/grade entered. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fill Scores/Grades for ALL STUDENTS in the Class 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Select Grading from the Menu Bar 

2. Select either Assignment List or Scoresheet: 

A. From the Assignments Screen > Click the Assignment Name to Open the Assignment Scoresheet 

B. From the Term Scoresheet > Locate the Assignment/Assignment Column in the Term Scoresheet 

3. Under the Assignment Column Click inside a student’s score/grade cell to Open the Score Inspector 

4. Enter the Score/Grade to Fill for ALL STUDENTS > Click the VERTICAL FILL ICON (Fill Icon with up and down arrows) 

5. Click Save Scores 

NOTES:  

 The teacher may include an Indicator Flag when entering the score/grade to be filled for all students 

 Any student who has a score/grade entered for the assignment will not be included in the fill scores/grades and their 

assignment score/grade will not be changed/altered when utilizing the Fill Function 

 

Fill Scores/Grades for ALL STUDENTS in the Class 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Verify or Select the Class that the student 

is enrolled in using the Select Class Menu/Dropdown Box at the top of the PowerTeacher Pro Gradebook screen 

2. Select the Student from the Class List > The Assignment Scoresheet will populate for the student showing only the individual 

student’s scores/grade for the selected term 

3. Under the Assignment Column Click inside the score/grade cell to Open the Score Inspector 

4. Enter the Score/Grade to Fill for ALL ASSIGNMENTS > Click the HORIZONTAL FILL ICON (Fill Icon with side to side arrows) 

5. Click Save Scores 

NOTES:  

 The teacher may include an Indicator Flag when entering the score/grade to be filled for all assignments 

 Any assignment that has a score/grade entered will not be included in the fill scores/grades and the assignment 

score/grade will not be changed/altered when utilizing the Fill Function 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Fill Function-Smart Text Comments Feature 

Teachers can Fill Comments when utilizing the Fill Function. Teachers can Fill a Comment for a specific assignment for all 

students in a class. When the teacher enters a comment that includes a Student Name or any Gender Pronouns, 

PowerTeacher Pro will detect this and when filling the comment for all students will replace the Student Name and/or 

Gender Pronoun with the students’ name/gender. Comments will not be filled for students or assignments that already have 

an assignment comment entered.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Fill a Comment for All Students: Using the Smart Text Comment Feature 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Select Grading from the Menu Bar 

2. Select either Assignment List or Scoresheet: 

A. From the Assignments Screen > Click the Assignment Name to Open the Assignment Scoresheet 

B. From the Term Scoresheet > Locate the Assignment/Assignment Column in the Term Scoresheet 

3. Under the Assignment Column Click inside a student’s score/grade cell to Open the Score Inspector 

4. Enter a Comment to be filled for all students in the Comment Box > Enter the First Name or First & Last Name of the Student 

in the Comment (Comments can be only 30 characters max) 

5. Click the VERTICAL FILL ICON (Fill Icon with up and down arrows) 

6. Select Scores, Flags and Comments or Comment Only from the Fill Options Menu 

7. The Names and Pronouns box will populate > Click Use Smart Text 

8. Click Save Scores 

NOTES:  

 Teachers will need to enter a Comment that contains the Name and/or Gender Pronoun in the Comment Box to utilize 

the Smart Text Comment Fill option 

 Teachers can also modify a Comment from the Comment Bank to add/include student names/gender pronouns 

 Any assignment that has a comment entered will not be included in the Comment Fill function and changes will not be 

made to the comments or scores/grades previously entered 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Final Grades/Calculation of Final Grades 

Final Grades for the Term are calculated/updated automatically throughout the term as teachers enter assignment 

scores/grades in the PowerTeacher Pro Gradebook. The Final Grade Calculation for each class is shown in the Grade 

Column on the Term Scoresheet. The Final Grade for the term is also calculated for each student on his/her Assignments 

Screen.  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 
 

 

 

 

 

FINAL GRADE 

CALCULATION FOR 

1ST QUARTER 

AUTOMATICALLY 

CALCULATED 

WHEN 

SCORES/GRADES 
ARE ENTERED 

NAVIGATION 
PowerTeacher > PowerTeacher Pro > Select Class > Verify Term > Students > Select Student > Assignments 

NAVIGATION 
PowerTeacher > PowerTeacher Pro > Select Class > Verify Term > Grades > Scoresheet 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  Manually Override/Modify a Final Grade 

Should teachers have a need to Manually Override a student’s Final Grade for the Term, they will want to complete the 

instructions below in the PowerTeacher Pro Gradebook. Teachers should modify BOTH the Percent (%) and GRADE. 

Teachers will only update the GRADE for the Term if they are intending to store a student’s Final Grade for the Term with an 

Incomplete (INC).  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

MANUAL OVERRIDE TRIANGLE INDICATOR 

A TRIANGLE in the upper-left corner of the Traditional 

Term Grade Calculation cell for a student indicates 

that the Final Grade Calculation was 
MANUALLY EDITED/CHANGED BY THE TEACHER 

Procedures to Manually Override a student’s FINAL GRADE for the TERM 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro 

Gradebook > Verify the Class Selected is accurate or Select the desired 

Class in the Select Classes Menu 

2. Select Grading from the Menu Bar > Select Traditional > Verify the Term is 

correct in the Term Menu on the upper-left corner of the screen 

3. Click Inside the Student’s Final Grade Cell to Open the Score Inspector 

4. Modify the student’s GRADE > Modify the student’s Percentage=%  

5. Click Save > Verify the student’s GRADE & % Match 

NOTE: A TRIANGLE will populate in the upper-left corner of the student’s 

 Final Grade Calculation to indicate the Final Grade was Manually 

 Changed/Modified by the teacher 

 

 

 

Procedures to Manually Override the FINAL GRADE for the TERM with an INC 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro 

Gradebook > Verify the Class Selected is accurate or Select the desired 

Class in the Select Classes Menu 

2. Select Grading from the Menu Bar > Select Traditional > Verify the Term is 

correct in the Term Menu on the upper-left corner of the screen 

3. Click Inside the Student’s Final Grade Cell to Open the Score Inspector 

4. Modify the student’s GRADE ONLY > Click the GRADE FIELD > Click CODES in 

the Score Inspector > Select INC  

5. Click Save > Verify that only the student’s GRADE was changed 

NOTE: The student’s GRADE will change to INC and there should be NO 

 CHANGE to the student’s Percentage % 

 A TRIANGLE will populate in the upper-left corner of the student’s 

 Final Grade Calculation to indicate the Final Grade was Manually 

 Changed/Modified by the teacher 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Recalculate Final Grades 

Teachers will use the Recalculate tool after making significant changes in the gradebook, or when the PowerTeacher 

Administrator changes settings that affect the gradebook.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Procedure to Recalculate Final Grades for the Term 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Verify/Select the Class in the Select 

Classes Menu 

2. Verify the Term is Current/Correct in the Term Menu on the top-left corner of the screen 

3. Click Grading in the Menu Bar > Select Traditional  

4. Click the GEAR Icon in the upper-left corner of the screen > Select Recalculate Final Grades 

5. Select Class or Classes in the Select Classes Menu/Dropdown Box on the Recalculate Final Grades Screen 

6. Check the Box for Traditional Final Grades Only 

7. Click Recalculate 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Final Grade Status 

Once teachers have finalized entering, updating, and making any necessary modifications to assignments or final grades 

they will notify the school Data Manager and/or PowerSchool Administrator that their grades for the reporting term have 

been finalized, and are ready to be stored. The Final Grade Status function allows teachers to report to the school Data 

Manager and/or PowerSchool Administrator if their Final Grades for the term are not complete/not ready to be stored and 

the date of expected completion. 

 

 

 

      
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

Final Grade Status – Term Grades Procedure 
1. From the PowerTeacher Start Page > Open the 

PowerTeacher Pro Gradebook > Verify the Class Selected 

is accurate or Select the desired Class in the Select 

Classes Menu/Dropdown Box 

2. Verify the Term is the current/correct Term in the Term 

Menu on the upper-right corner of the screen 

3. Select Grading from the Menu Bar 

4. Select Traditional 

5. On the Traditional Grades Screen > Click Final Grade 

Status (on the bottom of the screen) 

A.Term Grades are Final and Ready to be Stored: 

1. In the [Term] Final Grade Status Box > Check the 

[Term] Final Grades are Complete Box 

2. Enter a Comment (optional) as verification that 

grades are complete/finalized (this comment will be 

seen by the school Data manager/PowerTeacher 

Administrator) 

B. Term Grades are NOT Final/NOT Ready to be  

 Stored: 

1. DO NOT check the [Term] Final Grades are Complete 

Box 

2. Enter a Comment stating when grades for the term 

are expected to be finalized and ready to be stored 

6. Click Save 
 

NOTE: 

A GREEN CHECK MARK will populate next to Final Grade Status 

when the teacher CHECKS the completion box to indicate that 

the final grades for the term are complete. 

 

 

 

 

 

 

 

 

 

 

 

 

GRADES ARE COMPLETE/READY TO BE STORED 

GRADES ARE NOT READY 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Comment Verification  

Prior to submitting the Final Grade Status, teacher can use the Comment Verification to add a very brief comment to the 

report card. The Comment Verification function is used at the end of the term when completing/finalizing grades to post to 

report cards. Teachers can use the Comment Bank to add a comment to the Final Grade for the term. Any comments 

entered by teachers must be only 30 characters or less.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Comment Verification Procedures 

1. From the PowerTeacher Start Page > Open the PowerTeacher Pro Gradebook > Select the desired Class from the Select 

Classes Menu/Dropdown Box 

2. Select Grading from the Menu Bar > Select Comment Verification 

3. Verify the Term is current/accurate in the Term Menu on the upper-right corner of the screen 

4. On the Comment Verification Screen > Click Inside the Term Grade cell for a student to Open the Score Inspector 

A. Click the Comment Bank Icon > Select one Comment to add to the student’s term grade 

B. Enter/type a BRIEF (30 characters or less) Comment in the Comment Box at the bottom of the Score Inspector 

5. The Comment selected or entered will populate in the Comment Cell/Colum on the Comment Verification Screen > 

Review the Comments to ensure they meet the 30 character or less guideline 

6. Click Save  

  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

WARNING:  

 COMMENTS CANNOT BE OVER 30 CHARACTERS MAX 

 Comments over 30 characters cause performance 

issues in PowerSchool when generating report cards 

for the school. 

 

 

 

 

 

 

 

 

 

 

 

 

CATEGORY TOTALS 
Provides teachers with students’ Final Grades data, aggregated by 

Assignment Category 

PowerTeacher > PowerTeacher Pro > Grading > Category Totals 

ALL REPORTING TERMS 
Provides teachers with students’ Final Grades data for each 

Reporting Term 

PowerTeacher > PowerTeacher Pro > Grading > All Reporting Terms 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: PowerTeacher Pro Gradebook Reports  

The PowerTeacher Pro Gradebook contains Individual, Multi-Functional Assignment, Scoresheet, and Student Roster Reports 

that can be viewed on screen or printed. Teachers can personalize each report by entering a custom report title, including 

a top note, bottom note, or signature line. 

 

USING THE POWERTEACHER PRO GRADEBOOK REPORTS 

INDIVIDUAL STUDENT REPORTS  Use Individual Student Reports to VIEW or PRINT a 

summary of the class performance/activity per student 

 The Individual Student Report is used as a Mid-Term 

Update/Progress Report for students and parents 

 Course Grades, Attendance, Assignments, Category 

Totals, and Comments are options to include on the 

Individual Student Reports 

 Teachers can include one class or the students’ full 

schedule 

 Teachers can choose to include Student ID Numbers next 

to Student Names for identification purposes 

 Used to present a summary of student work to parents at 

conferences or to a principal during a review 

 This report can be printed for an individual student, a 

specific student selection, or for all students in a class/all 

students in all course sections 

MULTI-FUNCTION ASSIGNMENT REPORT  Use the Multi-Function Assignment Report to VIEW or 

PRINT a list of students and scores/grades per assignment 

 The Multi-Function Assignment Report can be used to find 

or run a report of Missing, Late, Incomplete, or Failing 

Assignment Scores/Grades 

 Used to help students and parents keep track of 

assignments or to identify students who may need 

additional educational support 

 This report can be used by teachers to gauge which 

assignments present the most challenges to students 

SCORESHEET REPORT  The Scoresheet Report is used to PRINT a copy of the 

Term Scoresheet 

 Teachers may include Final Grades and Assignment 

Scores/Grades 

 Teachers have the option to use Students’ Names OR 

Student ID Numbers 

 The Scoresheet Report can be sorted by Student Name, 

Student ID Number, or Randomly 

 The Scoresheet Report can be PRINTED using the Student 

ID Number option to post for students to review their class 

progress 

 The Scoresheet Report can be viewed as a PDF or 

Exported into an Excel Spreadsheet 

STUDENT ROSTER REPORT  Teachers will use the Student Roster Report to VIEW or 

PRINT demographic information by Class 

 Used to track required student information or materials 

including but not limited to: emergency 

contacts/contact forms, field tip deposits and permission 

slips, student attendance, and more 

 Teachers may customize the Student Roster Report by 

adding Blank Columns and/or Custom Column Headers 

or Sorting the Columns in the desired order 

 The Student Roster Report can be viewed as a PDF or 

Exported into an Excel Spreadsheet 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: How to Generate Individual Student Reports  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NAVIGATION:   PowerTeacher > PowerTeacher Pro > Reports > Select Individual Student Report 

1. CRITERIA TAB   
A. REPORT TITLE >  Enter a Custom Report Title matching that of the report being generated 

Example: Quarter 1 Progress Report 

B. SELECT CLASSES > Select the Class or Classes to include in the report 

C. CLASS NAME >  To use the previously customized class Name Check the Box next to Use Custom Class Name, otherwise the original  

Course/Section Name will be used 

D. STUDENTS’FULL SCHEDULE > DO NOT CHECK the Include Students’ Full Schedule when generating a Progress Report for a specific Class 

CHECK the Box to Include Students’ Full Schedule if generating a Progress Report for ALL Classes 

E. SORT OPTIONS > Layout:    By Section By Student  By Student     

NOTE:   If all Classes are included in the report By Section By Student would be Selected.  

   If only one Class is included in the report By Student would be Selected 

  Students:   Last Name   Student Number  

     First Name   Gradebook Preference 

  Assignments:   Due Date (Newest First) By Category/Due Date (Newest First) 

     Due Date (Oldest First)  By Category/Due Date (Oldest First) 

F. DATA > Areas to Include: Course Grades and Attendance / Course Grade Comments  

    Assignments / Assignment Comments 

   Category Totals 

  Show Percentages: Verify the Box is Checked/Selected to Include on the Report 

NOTE: To the Students’ ID Number with their Name on the report CHECK the Box next to   

 Include Student Number with Student Name 

G. DATA RANGE >  Student Assignments from the Current Grading Term is the Default Selection 

H. DATA FILTERS >  Use the DEFAULT Settings for Assignment Attributes, Assignment Scores, Assignment Categories, and Course Grades 

2. STUDENT TAB 
A. All Students are included in the Report by DEFAULT > To Include all students in the Report make no changes 

B. To Generate the Report for a specific Student Selection > Click Add/Remove Students 

C. Check the Box on the upper-right corner to the right of the Filter area to Deselect all Students > Check the Box next to the Specific Students to 

include in the Report 

3. FORMAT TAB 
A. PAGE ORIENTATION > Landscape is the recommended layout when including all available report data 

B. REPORT OUTPUT > PDF (default) 

C. PAGE BREAK >  Between Students is Selected by Default 

D. EXCLUDE ROW SHADING > Selecting this printing option will save ink 

E. TOP NOTE >  Type a brief note to include above the report data (OPTIONAL) 

F. BOTTOM NOTE >  Type a brief note to include above the signature line (OPTIONAL)  

G. SIGNATURE LINE > If a Parent/Guardian signature will be required CHECK the Box to Include on the Report, otherwise it is unchecked 

4. RUN REPORT 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: PowerTeacher Pro Gradebook Reports  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

MULTI-FUNCTION ASSIGNMENT REPORT 
NAVIGATION: PowerTeacher > PowerTeacher Pro > Reports > Multi-Function Assignment Report 

 Allows teachers to generate a report for Missing and Incomplete Assignments (screen 

example).  

 Used to assist students and parents in keeping track of assignments throughout the term or 

assignments that need to be completed/ turned in.  

 This report option can also be used as a Failure Report to include Missing, Late, Incomplete, 

and Failing Assignment Scores/Grades. 

 Can be Generated for one or more classes & specific student selections 

 To Generate: Criteria Tab > Students Tab > Format Tab > Run Report  
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: PowerTeacher Pro Gradebook Reports  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

SCORESHEET REPORT 
NAVIGATION: PowerTeacher > PowerTeacher Pro > Reports > Scoresheet Report 

 Allows teachers to generate the Term Scoresheet for one or more Classes or for an Individual 

Student  

 The Scoresheet Report can be Generated as a PDF or Exported into an Excel Spreadsheet 

 To Generate: Criteria Tab > Students Tab > Format Tab > Run Report 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: PowerTeacher Pro Gradebook Reports  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

STUDENT ROSTER  
NAVIGATION: PowerTeacher > PowerTeacher Pro > Reports > Student Roster 

 Allows teachers to generate a Student Roster for one or all Classes to track Student 

Attendance, Required Forms, Field Trip Information, Emergency Contacts, Etc… 

 Used in Sub Folders for Substitute Teachers to take Attendance 

 The Student Roster can be Generated as a PDF or Exported into an Excel Spreadsheet 

 To Generate: Criteria Tab > Students Tab > Format Tab > Run Report 

HOW TO GENERATE A CLASS ROSTER 
NAVIGATION: PowerTeacher > PowerTeacher Pro > Reports > Student Roster 

1. CRITERIA TAB   
A. REPORT TITLE > Enter a Custom Report Title matching that of  

 the report being generated 

EXAMPLE: Quarter 1 Class Roster 

 Required Forms & Parent 

Information 

B. SELECT CLASSES > Select the Class or Classes to include in the  

 report 

C. SORT OPTIONS > Select How Students will Appear on the  

 Roster 

 Last Name 

 First Name 

 Gradebook Preference 

 Birthday 

 Student Number 

 Grade Level 

D. DISPLAY > Add Columns  

Select the Information to Include on the 

Roster from  

 the Add Columns Menu 

NOTE:  Students’ Names are 

automatically displayed on the 

roster in the NAME Column 

 Add Blank Columns   

 Click the Add Button next to Blank to Insert 

Blank Column Headers that can be 

customized 

 Modify the Order of Columns as Desired 

using the Up and own Arrows 

2. STUDENT TAB 
A. All Students are included in the Roster by DEFAULT > To Include all 

students on the Roster make no changes 

B. To Generate a Roster for a specific Student Selection > Click 

Add/Remove Students 

C. Check the Box on the upper-right corner to the right of the Filter area to 

Deselect all Students > Check the Box next to the Specific Students to 

include in the Report 

3. FORMAT TAB 
A. PAGE ORIENTATION > Select Landscape or Portrait 

B. REPORT OUTPUT > PDF (default) or Export to Excel 

C. PAGE BREAK >  Between Classes is Selected by Default 

D. EXCLUDE ROW SHADING > Selecting this printing option will save ink 

E. TOP NOTE >  N/A for a Class Roster 

F. BOTTOM NOTE >  N/A for a Class Roster 

G.SIGNATURE LINE > N/A for a Class Roster 

4. RUN REPORT 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: Analyzing Class Performance  

The PowerTeacher Pro Gradebook allows teacher to analyze Class Performance/Progress throughout the academic year. 

 

 

 

 

 

 

  

Traditional Grades Progress Screen & Features 

 The Traditional Grades Progress Screen provides a graphical view 

of the grade distribution for the selected class and selected 

reporting term. 

 The Information Icon will provide the Traditional Grades included 

in each color level. 

 To the right of the graph, teachers can view a summary of 

Missing, Late, and Incomplete Assignments 

 Clicking the View All button under the graph will Open the 

Traditional Grades Distribution window. 

 On the left side of the Traditional Grades Distribution window 

teachers can view the GRADE DISTRIBUTION for each Reporting 

Term in the academic year. 

 On the right side of the Traditional Grades Distribution widow 

teachers can view the GRADE TRENDS for the students in the 

Selected Class for the Reporting Terms Selected or compared to 

the previous Reporting Term. (In the screen shot provided the 

teacher selected Semester 1 (S1) as the Reporting Term to 

compare to Q1). 

 A RED ARROW in the Grade Column indicates a student’s grade 

is trending DOWN between the selected terms. 

 A GREEN ARROW in the Grade Column indicates a student’s 

grade is trending UP between the selected terms. 

 NO ARROW in the Grade Column indicates there is no change. 

 To Compare trends between a different selection of subsequent 

terms, teachers will Click the GEAR Icon on the upper-right 

corner of the Traditional Grades Distribution window and Select 

the desired term. 

 Clicking OK on the bottom-right OR the X in the upper-right 

corner of the Traditional Grades Distribution window will Close 

the Window. 

 To Select a different Term on the Traditional Grades Progress 

Screen the teacher will change the Selected Term in the Term 

Menu on the upper-right corner of the screen. 

 

TRADITIONAL GRADES PROGRESS 
NAVIGATION: PowerTeacher > PowerTeacher Pro > Select a Class > Progress > Traditional 

 

 

 

 

 

  

 



PowerTeacher & PowerTeacher Pro Gradebook 
SUPPORT/TRAINING GUIDE FOR HIGH SCHOOL YEARLONG COURSES 

 
 

Page | 47 

CMS PowerTeacher/PowerTeacher Pro Gradebook  

 

 

PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  

Individual Student Data, Assignments, and Information  

The PowerTeacher Pro Gradebook allows teachers to view individual student data, enter/modify their assignment 

scores/grades, and view information for the individual student. 

 

 

 

  

INDIVIDUAL STUDENT DATA, ASSIGNMENT SCORES/GRADES, AND INFORMATION 
NAVIGATION: PowerTeacher > PowerTeacher Pro > Select a Class > Students > Select a Student 

STUDENTS > SELECT STUDENT > ASSIGNMENTS 
The Assignments Screen allows the teacher to view a Summary of all the scores/grades for all 

assignments in all Reporting Terms for the selected student. Teachers can enter or modify 

scores/grades for the selected student from the student’s Assignments screen. 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  

Individual Student Data, Assignments, and Information (continued) 

  

STUDENTS > SELECT STUDENT > COMMENT LOG 
 The Comments Log allows the teacher to view a Summary of all the comments 

entered/recorded for the selected/individual student. 

 Teachers can modify comments by clicking Inside the Grade/Score Column to Open the 

Score Inspector from the Comments Log Screen.  

 Teachers will be able to view Assignment and Reporting Term Comments for the Individual 

Student. 

 

 

 

 

 

STUDENTS > SELECT STUDENT > DEMOGRAPHICS 
The Demographics Screen provides the teacher with the selected student’s personal 

demographics such as address, parent/guardian names and contact information, date of 

birth, etc… 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES:  

Individual Student Data, Assignments, and Information (continued) 

 

 

  

 

 

 

STUDENTS > SELECT STUDENT > QUICK LOOKUP-TRADITIONAL 
 The Quick Lookup Screen provides the teacher will the students full academic progress and attendance data for the current academic year 

 Clicking the Show Dropped Also Link will provide the teacher with the student’s academic progress and attendance from another CMS School or 

from another North Carolina Public or Charter School of previous enrollment (within the current academic year). 

 Click on the Blue Grade under the Reporting Term will open the Reporting Term Window showing all assignments and Details for the assignment, 

including any comments entered by the previous teachers. 

 The teacher will utilize the Quick Lookup Screen when obtaining grades to transfer into their gradebooks for any new students from another CMS 

teacher, CMS School, NC Public School, or NC Charter School. 

 

STUDENTS > SELECT STUDENT > POWERTEACHER PORTAL 
 The PowerTeacher Portal link will open the teacher’s PowerTeacher 

Account in a NEW Window allowing the teacher to not lose his/her place 

in the PowerTeacher Pro Gradebook. 

 The teacher will be taken directly to the selected student’s information 

screens in PowerTeacher to view additional information/screens as they 

are available. 

 The PowerTeacher Portal can also be found under the Apps Charm 
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PowerTeacher Pro Gradebook for HIGH SCHOOL YEARLONG COURSES: PowerTeacher Pro Help & CMS Support 

For additional help teachers can click on the Help Icon on the upper-right corner of the PowerTeacher Pro Gradebook to 

access the robust PowerTeacher Pro Help System, which includes A-Z help articles, tips and tricks, How To Videos, and much 

more. For CMS Specific PowerTeacher Pro Support teachers can visit the CMS Intranet: PowerSchool Updates & Information 

Site and view CMS PowerTeacher Instructional Documents and Videos from the Training Documents and Videos Page. For 

additional support teachers will see their school’s PowerTeacher Pro Gradebook Trainer or Data Manager. Teachers are 

welcome to utilize the CMS PowerSchool Help Desk or enter a PowerSchool Cherwell Ticket for further support. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

CMS Employee Intranet: my.cms.k12.nc.us 

 Login with your CMS Email & Password 

Click PowerSchool Updates & Information 

Click the Training Documents & Videos Link 

 Submit a PowerSchool Cherwell Ticket 

Contact the CMS PowerSchool Help Desk 980.343.5736, Opt 2 
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2018-2019 

HIGH SCHOOL YEARLONG COURSES: Final Grade Calculation Setups & Assignment Category Verification 

 

SCHOOL NAME  ___________________________________________________________________ 

 

TEACHER NAME  ___________________________________________________________________ 

 

2018-2019 TEACHER/TEACHER OF RECORD VERIFICATION OF GRADEBOOK/FINAL GRADE SETUPS 
 

 
I _________________________________ (CMS teacher/teacher of record) have viewed and verified my 2018-2019 Pre-Defined Final 

Grade Calculations. I have not setup or modified any Pre-Defined Final Grade Calculations. I have completed my Yearlong Final 

Grade-Traditional Grade Calculation Setups as instructed, following the Charlotte-Mecklenburg School Final Grade Setup 

guidelines for HIGH SCHOOL YEARLONG COURSES. I have read and understand that I am not to create additional Assignment 

Categories for any assigned classes/courses, and that if I choose to do so that the additional assignment categories will not count 

in the Final Grade Calculation. In addition, I understand that my gradebook is subject to review by the school and district 

administration to ensure accuracy in reporting. Should I alter the gradebook setup in a manner that changes the Final Grade 

Calculations for the students scheduled in my course sections at any time during the academic term, I will be required to make the 

necessary corrections to correct my gradebook setup as instructed by school administration or the district PowerSchool 

administration. 
 

2018-2019 COURSE SECTIONS: Complete the following and initial indicating that the Final Grade Setup & Categories are Correct 

Course Name  Course Number  Section Number  Length of Course Teacher Initials 

 

______________________ ______________________ _______________  _________________ _______________ 

 

______________________ ______________________ _______________  _________________ _______________  

 

______________________ ______________________ _______________  _________________ _______________ 

 

______________________ ______________________ _______________  _________________ _______________  

 

______________________ ______________________ _______________  _________________ _______________ 

 

______________________ ______________________ _______________  _________________ _______________  
 

 
To be Completed by the PowerTeacher Pro Gradebook Trainer  
 

 

I ____________________________ (PowerTeacher Pro Gradebook School Trainer) have reviewed the PowerTeacher Pro Gradebook for the 

above named teacher and/or teacher of record. I verify that the above teacher/teacher of record has properly completed the 2018-2019 

Final Grade Setup procedures according to the Charlotte-Mecklenburg School Final Grade Setup-Traditional Grade Calculations for HIGH 

SCHOOL YEARLONG/36-WEEK COURSES. I have personally reviewed each Course Section listed above/assigned to the teacher/teacher of 

record named above to verify that the Final Grade-Traditional Grade Calculation Setup is correct and accurate. In addition, I have 

ensured that the teacher has not created any additional Assignment Categories and is aware that no assignments should be created for 

any courses throughout the academic year/term and that the Final Grade Calculations should not be modified. 
 

REQUIRED SIGNATURES:   Teacher/Teacher of Record & PowerTeacher Pro Gradebook Trainer 

OPTIONAL SIGNATURES/REVIEW: Administrative Team Member  

 

_______________________________________   ___________________________________ ______________________ 
Teacher/Teacher of Record Name (PRINT: First & Last Names)  Teacher Signature    Date 
 

 

_______________________________________   ___________________________________ ______________________ 
PT Pro Gradebook Trainer Name (PRINT: First & Last Names)  PT Pro Gradebook Trainer Signature   Date 
 

 

_______________________________________   ___________________________________ ______________________ 
Administrator Name (PRINT: First & Last Names)   Administrative Signature    Date 

 

DATA MANAGERS 
All forms are to be kept on file with the school Data Manager. Data Managers will verify the form for completion and the required signatures have been 

obtained. 
 

 ALL REQUIRED INFORMATION IS COMPLETE & REQUIRED SIGNATURES HAVE BEEN OBTAINED DATE RECEIVED/FILED:  _______________________ 


